Bei meinem Buspirate schlug nach längerer "Standzeit" (ja, ich gebe es zu - er lag ungeschützt in einer Schublade) der Selbsttest fehlt.

Das ganze sah dann in TeraTerm so aus:

HiZ>~
Disconnect any devices
Connect (Vpu to +5V) and (ADC to +3.3V)
Space to continue
Ctrl
AUX OK
MODE LED OK
PULLUP H OK
PULLUP L OK
VREG OK
ADC and supply
5V(1.34) FAIL
VPU(1.37) FAIL
3.3V(3.24) OK
ADC(3.37) OK
Bus high
MOSI OK
CLK OK
MISO OK
CS OK
Bus Hi-Z 0
MOSI OK
CLK OK
MISO OK
CS OK
Bus Hi-Z 1
MOSI FAIL
CLK FAIL
MISO FAIL
CS FAIL
MODE and VREG LEDs should be on!
Any key to exit
Found 6 errors.

Schuld war ein defekter 5V Spannungsregler, jener mit der Kennzeichnung LB50 (oder war es KB50?). Dieses Bauteil befindet sich unterhalb der RX/TX LEDs. Wir benötigen daher einen neuen Festspannungsregler 5V im SOT23-5 Package mit mind 150mA.

In Deutschland ist das Original als Privatperson nicht ganz so einfach zu bekommen (Micrel 5205, http://www.micrel.com/_PDF/mic5205.pdf). Einfacher auftzutreiben ist der LP2985AIM5-5, z.B. bei eBay. Dieser ist Pin-kompatibel und verträgt sogar bis zu 350mA!

Austausch

Es handelt sich um ein wirklich sehr kleines SMD-Bauteil. Bitte reißt keine Pads ab beim versuch das Teil auszulöten. Falls ihr mit dem Lötkolben arbeiten wollt, dann schneidet am besten vorher die Beinchen mit einem scharfen Messer durch und entfernt diese dann einzeln mit dem Kolben.

Ergebnis

Nach dem Austausch war alles wieder wie zuvor:

HiZ>~
Disconnect any devices
Connect (Vpu to +5V) and (ADC to +3.3V)
Space to continue
Ctrl
AUX OK
MODE LED OK
PULLUP H OK
PULLUP L OK
VREG OK
ADC and supply
5V(5.07) OK
VPU(5.01) OK
3.3V(3.31) OK
ADC(3.22) OK
Bus high
MOSI OK
CLK OK
MISO OK
CS OK
Bus Hi-Z 0
MOSI OK
CLK OK
MISO OK
CS OK
Bus Hi-Z 1
MOSI OK
CLK OK
MISO OK
CS OK
MODE and VREG LEDs should be on!

Ersparnis: 30$ (Neupreis) - 5€ (Ersatzteil im 5er Pack)

Besucher-Aktionen

Ich freue mich über einen Kommentar! Das geht auch als Gast: mit Disqus einloggen » als Gast.